Displying PNG Icons on Workbench

Recently I re-installed AmigaOS4.1 on my little Sam440ep due to the fact I kind of broke my old install by being tired and drunk and making stupid changes to the installed OS. The installation of the OS was a breeze but I came across an interesting thing which stumped me a bit since it has been a few years since I did the initial installation. The problem was that PNG based icons were not displaying correctly.

The System would detect that the icon was a PNG but not actually display the icon but instead display the default PNG icon for PNG files which have no icon associated with it. When you double click the deficon, it would display the icon image as it should be and not actually start the programme.

Gish PNG icon before png.iconmodule installation.

Gish PNG icon before png.iconmodule installation.

Turns out that this is relatively easy to fix. All you need to do is go to OS4Depot and grab the PNG icon module and then install it. To install, all I had to do was to create an IconModules directory within the libs: dir and copy the png.iconmodule file from the before mentioned png_im archive. Once the system is given a 3 finger salute, all is well in the world again and you now have access to the multitude of pretty PNG icons which are available for the Amiga.

Gish PNG icon after png.iconmodule installation.

Gish PNG icon after png.iconmodule installation.

NB: Ignore the .exe extension. In Amiga land we usually don’t use such things and I have not been bothered changing it. I am guessing it is there since Gish has been ported to the Amiga from the Windows/Linux world.

On the subject of re-installing. About 9 months ago I bought a new case for my Sam440ep motherboard to go into as the PSU had died on the old one. Now, I know they claim that these motherboards have a low power requirement and they were not joking. With motherboard, HD and CDROM plugged in, the system would not power up since it was not putting enough load on the PSU. I ended up plugging a PCI card into the computer which pushed its power usage up enough for the load to register on the PSU and allowing the computer to power on.

Tagged , . Bookmark the permalink.

Leave a Reply