What a Crappy Google+ Feature!

I went to post my previous post on Google+ via my Amiga using a browser called MUI OWB  which is based on the Webkit engine only to be told by Google+ that it is not supported. I clicked on the learn more link and got told to download a few different browsers and also noticed the plus link at the top so clicked on that only to be returned to the same ‘your browser is not supported’ page. No where could I see how to get to the plus part of the page to post the link.

I decided to try a port of Firefox which has been done on the Amiga but is still in beta, called Timberwolf and it let me into the part of Google+ to be able to post the link.

I have no problems with Google telling me my browser is not supported BUT I think it is crappy as hell that they then stop you from doing anything on the site just because your browser is not a Google state sponsored browser. Pretty crappy effort Google.

Stupid Hardware Problems

I finally got off my lazy butt and bought a replacement hard drive for my main computer that had a disk failure. Why lazy? Well, the drive failed a good 6-7 months ago.

Let me start from the beginning.

I recently moved, well relatively speaking it was recent, in March this year. Just before doing this I had yet more problems with already problematic hardware and had one of four drives fail in my main computers RAID10 set. No problem, that is one of the reasons I am running RAID10 (I picked up an old 3ware 4 drive SATA RAID controller cheap and thought why not). The plan was to replace the drive after the move.

This would have been fine if it wasn’t for the fact that the RAID controller proceeded to die at about the same time that the house move started in earnest. Within a week of moving to my new place of residence, I went to do a temporary Windows/Linux dual boot install on a spare disk I had only to also discover the motherboard had also died! ARGH!

First thing first, I bought a new motherboard but since I could not get one with the same chipset and also needing a compatible RAID controller, I just went ahead with the temporary setup. The new motherboard and CPU is nice, being an AM3+ Gigabyte motherboard (sorry, I can’t remember the model number) with an AMD FX 6 core 3.3Ghz CPU.

With getting my main work horse sort of back up and running again, I was then able to track down a compatible controller which I could plug my existing RAID set into in the form of a 9650SE-8LPML RAID controller with Battery Backup unit, again much nicer than my old 9650SE-4 controller which was missing the BBU and it was cheaper as well. Yay EBay.

The new controller was purchased 3 months ago. Yesterday I finally got the before mentioned disk. The pain has now begun.

This morning I connected the old RAID set to the new controller and found it to be in a degraded state (it lost a disk) and needing to verify what was still there. So I had to wait a few hours for the verify to finish. When it finished, I shut the machine down, replaced the dead disk and powered the system back up. At which point I proceeded to choose the RAID set and the new disk and told it to rebuild. Nope, apparently I did something wrong. The controllers BIOS was telling me I needed to choose the RAID and a spare disk and then select rebuild but that’s what I did!

I stuffed around with it a bit more, same results, then it dawned that the spare disk was automatically in a state of JBOD (Just a Bunch of Disks). Hrmmm, maybe it classifies that as a disk in use. I told the controller to remove the disk and low and behold, when I select it and the RAID set requiring the new disk and select rebuild it finally does!

At the moment, I am typing this up on my little AmigaOS4.1 machine while I get to which the RAID rebuild on my main machine. Which is about as much fun as watching paint dry. Once that is complete, I get to enjoy making both Linux and Windows play nice with the new motherboard chipset. I am hoping it will not be to painful. They both boot and it appears I really only need to fix the USB3 and ethernet drivers on both OS installs but until that is all working, I am not going to hold my breath. The amount of times I have seen something that appears to be easy on the surface and then have it turn into an extremely painful exercise in the IT world is amazing.

Humble Bundle 5 – A new Humble Bundle

As the spiel states: Pay what you want, help charity, get cross-platform, DRM-free games. All good reasons to get this bundle.

Point your browser at http://www.humblebundle.com/ and have a look. I was impressed with the games they have in this bundle and bought it as soon as I got the email which is why my post is a day or two behind the official release, I have been busy playing the games.

This bundle includes:

  • Bastion (only if you pay above the average).
  • Amnesia: The Dark Descent.
  • Psychonauts.
  • Limbo.
  • Superbrothers: Sword & Sworcery EP.
  • As well as the music tracks for all the games.

I will admit to one gripe I have with this pack and that is with Psychonauts. I am loving the game BUT it is buggy as hell under Linux and has a bad habit of crashing during cut scenes. I really hope they get some fixes going for it and soon because it is sending me spare.